Unplanned Maintenance

Incident Report for Everidge IT Status Page

Resolved

This incident has been resolved.
Posted Sep 14, 2026 - 23:02 CDT

Investigating

We are currentlty performing unplanned urgent maintenance on our network and server infrastructure. Some services may not be available.
Posted Sep 14, 2026 - 20:48 CDT
This incident affected: Dynamics AX - PROD, Computair - PROD, Dynamics AX - TEST, and Computair - TEST.