Email Processing Issue

Incident Report for Everidge IT Status Page

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 16:04 CDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 18, 2026 - 14:14 CDT

Identified

We are aware of a current issue with Mimecast that may impact email deliverability due to temporary DNS resolution failures within their environment.

Mimecast is actively investigating, and we are monitoring for any updates.
Posted Mar 18, 2026 - 14:13 CDT

Investigating

We are currently investigating this issue.
Posted Mar 18, 2026 - 14:10 CDT
This incident affected: Mimecast (Mimecast Email Processing) and Microsoft 365.